HEY has delays receiving email
Incident Report for 37signals
Resolved
HEY email delivery is back! We'll continue to monitor it to make sure it's stable. So sorry for the interruption today, folks.
Posted Nov 03, 2022 - 16:04 UTC
Investigating
HEY may be experiencing delays receiving email . We're investigating the root cause and will provide updates as soon as we can. Sorry for the interruption, everyone.
Posted Nov 03, 2022 - 16:02 UTC
This incident affected: HEY.