Status
Launchpad is down
Incident Report for
37signals
Resolved
Launchpad is back up! Sorry for the interruption!
Posted
Jun
17
,
2025
-
23:01
UTC
Identified
We've identified and issue that is preventing users from logging into Basecamp accounts via our Launchpad.
Posted
Jun
17
,
2025
-
23:00
UTC
This incident affected: Basecamp 4.
×
Subscribe to Incident
Subscribe to updates for
Launchpad is down
via . You'll receive .